FAQ не читали, судя по вопросу.
Для удаления вводятся команды со значением no впереди -
no dial-peer voice 100 pots
Учите Cisco CLI.
Код: Выделить всё
Current configuration:
!
version 8.51.002
!
hostname GS1002
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address dhcp
no ip dhcp unicast
ip nat outside
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.88.51 255.255.255.0
ip nat inside
speed auto
no qos-control
!
ip route 0.0.0.0 0.0.0.0 192.168.88.1 10
!
!
!
!
http server
!
dns name-server 192.168.88.1
logging command
logging event 4-warning
logging on
!
!
!
!
! VoIP configuration.
!
!
! Voice service voip configuration.
!
voice service voip
protocol sip
dtmf-relay out-of-band
fax protocol t38 redundancy 0
fax rate 9600
h323 call start fast
h323 call tunnel enable
no call-barring unconfigured-ip-address
no voip-inbound-call-barring enable
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
no caller-id enable
!
!
! GSM
voice-port 0/1
no caller-id enable
!
!
! FXS
voice-port 0/2
no announcement
no caller-id enable
!
!
! FXS
voice-port 0/3
no caller-id enable
!
!
!
!
! service port group configuration.
!
!
!
! Pots peer configuration.
!
dial-peer voice 1 pots
destination-pattern 301
port 0/2
user-name Addpac1
user-password addpac301
!
!
!
! Voip peer configuration.
!
dial-peer voice 301 voip
destination-pattern T
session target sip-server
session protocol sip
answer-address T
voice-class codec 1
no vad
no dtmf-relay
!
!
!
!
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
h323-id voip.192.168.88.13
no ignore-msg-from-other-gk
register
!
!
! Codec classes configuration.
!
voice class codec 0
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g7231r53
codec preference 4 g7231r63
codec preference 5 g729
!
!
!
! SIP UA configuration.
!
sip-ua
user-register
sip-server 192.168.88.13
call-transfer-mode attended
remote-party-id
register e164
!
!
! Tones
!
!
!
!
line console
!
line vty
!
gsm dev-restart-by-unreg 300
!
gsm 0/0
sms-language utf8
!
gsm 0/1
sms-language utf8
!
end
Код: Выделить всё
dial-peer voice 0 voip
destination-pattern T ! пропускаем любые цифры
session target sip-server ! на сип сервер который настроили в SIP-UA
session protocol sip ! протокол (SIP/H.323)
voice-class codec 1 ! устанавливаем класс кодеков
no vad ! выключаем детектор голоса
dtmf-relay rtp-2833 ! устанавливаем DTMF RFC-2833
Сорри, не уточнил что это конфиг 1002C с FXO портами. Привел как типовой пример настройки gsm&fxo обычно такие шлюзы ставим.ded писал(а):Не хотите всё таки FAQ почитать?
Вы глупости в конфиге пишете. Порт FXS - это конкретный телефон, конкретный номер, например - 301. Можно конечно его втыкать в порты СО другой станции, но это уже изврат.
!
dial-peer voice 301 voip
destination-pattern T - это не FXO, он не принимает ЛЮБЫЕ НОМЕРА ЛЮБОЙ ДЛИНЫ!
надо
destination-pattern 301
тогда он зарегистрируется ЭТИМ е164 номером (301) на прокси-сервере (Астериск).
И включите sip debug ip ip_addr_AddPac
BooM писал(а):Right?
ded писал(а):Не хотите всё таки FAQ почитать?
Код: Выделить всё
Current configuration:
!
version 8.51.002
!
hostname GS1002
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address dhcp
no ip dhcp unicast
ip nat outside
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.88.51 255.255.255.0
ip nat inside
speed auto
no qos-control
!
no ip routing
ip route 0.0.0.0 0.0.0.0 192.168.88.1 10
!
!
!
!
http server
!
dns name-server 192.168.88.1
logging command
logging event 4-warning
logging on
!
!
!
!
! VoIP configuration.
!
!
! Voice service voip configuration.
!
voice service voip
protocol sip
dtmf-relay out-of-band
fax protocol t38 redundancy 0
fax rate 9600
h323 call start fast
h323 call tunnel enable
no call-barring unconfigured-ip-address
no voip-inbound-call-barring enable
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
no caller-id enable
!
!
! GSM
voice-port 0/1
no caller-id enable
!
!
! FXS
voice-port 0/2
connection plar 301
no announcement
no caller-id enable
!
!
! FXS
voice-port 0/3
no caller-id enable
!
!
!
!
! service port group configuration.
!
!
!
! Pots peer configuration.
!
dial-peer voice 0 pots
destination-pattern 301
port 0/2
user-password addpac301
!
!
!
! Voip peer configuration.
!
dial-peer voice 101 voip
destination-pattern 301
session target sip-server
session protocol sip
voice-class codec 1
no vad
dtmf-relay rtp-2833
!
!
!
!
!
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
h323-id voip.192.168.88.13
no ignore-msg-from-other-gk
register
!
!
! Codec classes configuration.
!
voice class codec 0
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g7231r53
codec preference 4 g7231r63
codec preference 5 g729
!
!
!
! SIP UA configuration.
!
sip-ua
user-register
sip-server 192.168.88.13
call-transfer-mode attended
remote-party-id
register e164
!
!
! Tones